3
votes
0answers
44 views

Byte Order Mark suddenly appearing in query results

Query results seem to have started including BOMs sometime today. I had to add code to handle it. I don't see this documented anywhere.
5
votes
1answer
42 views

API documentation pages match some site names incorrectly

The bug is not in the API itself, but in the pages documenting its methods. To reproduce, follow the link http://api.stackexchange.com/docs/info#filter=default&site=math and observe that the page ...
4
votes
1answer
58 views

“Try it” facility suffers a double-encoding bug

As you can clearly see from the above, the ampersand in the site name in the "Try It" section of the API method documentation has been double-encoded. This affects any site with an ampersand in ...
9
votes
1answer
136 views

Google’s OAuth redirect broken

We just tried to authenticate with our application without being logged into anything on StackExchange. This is best tested in a private browser session without any cookies etc. So after starting the ...
3
votes
1answer
95 views

“OAuth request must be over HTTPS” when request is over https

I had a bug reported to me that I was able to reproduce. When authorizing to my Badges webapp, we get the following error: error: invalid_request error description: OAuth request must be over ...
3
votes
1answer
43 views

Trying to get the Total results count crashes the /notifications path

I am trying to use the filter !9ciXfDSYM (same as default but with total) with the /notifications request and the response is: { "error_id": 500, "error_name": "internal_error", ...
4
votes
1answer
58 views

API calls that return select post bodies throw JSON errors

When calling the Stack Exchange API to get the post body, it will return an error for some posts. EG: ...
6
votes
1answer
61 views

/users/{ids}/timeline creation_date missing or incorrect

I am writing a small widget that displays the time since I was awarded my last badge on Stack Overflow. I noticed that my most recent badge was missing from the timeline data (/users/{ids}/timeline). ...
0
votes
1answer
43 views

Most of the url are missing the protocol

Maybe you were trying to fix the other "bug" I've pointed out, but now most of the url for the icons are missing the protocol! { "site_type": "main_site", "name": "Stack Overflow", ...
4
votes
2answers
51 views

Stack Exchange API is returning boolean(false) For 'is_answered' On Question With Accepted Answer

When you view this question you see a closed question which has an accepted answer. When you get the API info for it you get this: ["question_id"]=> int(17466804) ["creation_date"]=> ...
2
votes
1answer
46 views

Stack Exchange API is returning non-existant/incorrect notices for questions

When you view this question you do not see any notices other than the protected notice at bottom. Also, you are able to edit the answers and question (provided you have the privilege). However, when ...
12
votes
1answer
62 views

Stack Exchange API is not returning the close vote counts for questions

When you visit this question (with proper privs) you can see that there are 2 close votes cast for it. However, if you access the information for this question using the Stack Exchange API you get ...
2
votes
1answer
22 views

Default listing images aren't served from CDN, fail to load because of certificate error

The default images used on the app/script/library pages aren't pointing to the CDN, so their use of HTTPS causes a certificate error that prevents the image from loading: Could the image sources be ...
3
votes
1answer
36 views

The API has stopped allowing CORS requests

I just noticed that a script I have that makes CORS requests to the API stopped working on Meta Stack Overflow, claiming that the domain isn't allowed by Access-Control-Allow-Origin, which is true ...
0
votes
1answer
47 views

CDN redirect for the API's JavaScript SDK is incorrect

The API's JavaScript SDK is listed as https://api.stackexchange.com/js/2.0/all.js. However, GET request produces the following response: Status Code: 301 Moved Permanently Location: ...
1
vote
1answer
50 views

Off-by-one error in fromdate processing

When running a query with a given fromdate value, values which match fromdate - 1 are returned. An example: When using fromdate=1367715851 results will be returned which have a creation_date of ...
8
votes
1answer
50 views

Whatever happened to closed_reason?

When pulling back info on a closed question, I have come to expect closed_reason to be a present key if there's a closed_date. It seems that as of recently this is no longer true. Proof: ...
3
votes
1answer
44 views

Problem with /search tagged and max

Seems like a problem with /search when max is not set to today, and tagged is given: ...
3
votes
1answer
110 views

API documentation console unsuccessfully tries to load MiniProfiler results

All of the documentation pages (example) with the test console currently attempt to load MiniProfiler result data, which fails with a 404: POST ...
4
votes
1answer
33 views

Typo in the docs for /me

The doc says: Returns the user associated with the passed auth_token. This method returns a user. It should say "access_token" instead of "auth_token".
3
votes
1answer
31 views

Querying “standard meta tags” for their tag wikis wrongly says they have none

I'm checking which tags have tag wiki excerpts in my code. It looks like /tags/{tags}/wikis is the right API since the tag info API doesn't even give a boolean for tag wiki excerpt presence. But ...
1
vote
1answer
19 views

The “Get Started” section in the sidebar only mentions API 2.0 and API 1.1

Now that API 2.1 is "public, frozen, and out the door" shouldn't we update the "Get Started" section in the sidebar on the right side of the screen. It talks about API 2.0 and API 1.1 but doesn't ...
1
vote
1answer
15 views

No token field in the docs test page for /me/reputation-history

There is no form field for an access token at: https://api.stackexchange.com/docs/me-reputation-history https://api.stackexchange.com/docs/me-full-reputation-history After attempting to Run the ...
10
votes
1answer
246 views

Bug in the StackExchange Api ? getting “could not parse proxy url” when user not logged in

I think I may have stumbled upon a bug in the StackExchange JS API I'm having a problem getting its authentication to work properly, and I just discovered that the same problem exist in the official ...
4
votes
1answer
11 views

Typo in API filter documentation

When using unsafe filters, the API returns the highest fidelity data is can reasonably access for the given request. should be When using unsafe filters, the API returns the highest fidelity ...
2
votes
1answer
31 views

Error retrieving question using a filter that includes question.notice

I have created a filter to include the question.notice field. It seems to be OK as returned by https://api.stackexchange.com/2.1/filters/-9xc1l%2Au-JEsf_Q Then if I want to fetch this question using ...
5
votes
1answer
46 views

Typos in the API 2.0 Documentation

Typo #1: There are two different objects that represent a user in the Stack Exchange API, the full user object and the smaller shallow_user object. Which is returned depends on the method being ...
2
votes
1answer
57 views

Stack Apps graph time filters make pretty much no sense

When viewing the Query Statistics graphs for an application, you have the option of choosing 'Week', 'Month', 'Year', or 'All Time'. When hovering over 'week' it states "view stats for the last 7 ...
2
votes
1answer
27 views

Advanced search by title doesn't filter on the title

Searching by title on the advanced search method doesn't restrict the results to posts containing the specified text as a word or even substring. Varying the string has some influence, but I can't ...
2
votes
1answer
22 views

View count restriction isn't working for /search/advanced.

I have constructed the following URL, but the questions returned don't contain anywhere near 50k views, despite the query string parameter: ...
5
votes
1answer
31 views

/posts/{id}/revisions breaks for posts with [tag:*] content

Attempting to access (at least) the revisions route for a post with a revision involving the [tag:*] syntax causes an error: Example on Meta Stack Overflow (Post History) Example on Mathematica ...
1
vote
1answer
14 views

Question count missing from network_user

Docs state that you get an int question_count from a network_user object but I'm not getting these fields back anymore - even when testing from https://api.stackexchange.com/docs/me-associated-users ...
2
votes
1answer
47 views

/suggested-edits “Try it”: Link for “suggested_edit_id” is broken

When using the "Try it" feature on /suggested-edits, the link for the suggested_edit_id points towards stackexchange.com and not towards the respective site. For example, retrieve data using the ...
1
vote
1answer
49 views

/me API endpoint returning 500 error

I'm making an authenticated call to /me: https://api.stackexchange.com/2.0/me?access_token=[redacted]&site=stackoverflow&key=[redacted] But it's returning: ...
3
votes
1answer
43 views

Typo in API docs: “temporarility_unavailable”

https://api.stackexchange.com/docs/authentication "temporarility" should probably be "temporarily"
2
votes
1answer
27 views

/answers endpoint is error-500-ing against many sites

Just calling the "/answers" endpoint, no specific arguments, and I'm getting 500 errors: http://api.stackexchange.com/2.0/answers?order=desc&sort=activity&site=gaming ...
2
votes
1answer
40 views

Does /invalidate work for no-expiry tokens?

It seems that tokens created with no_expiry scope are immune to requests to invalidate them with /access-tokens/.../invalidate. Is this by design or by bug?
1
vote
1answer
26 views

Inbox unread since parameter not working

The since parameter of /inbox/unread no longer seems to work. I enter a date after the creation date of the item currently unread in my inbox and still the item is returned. I try putting in ...
0
votes
0answers
405 views

Receiving “redirect_uri does not match the uri used to create the passed code”, when it does match

Summary Using Oauth2, when I go to pick up the access_token, I get the following error from the server: access_denied: redirect_uri does not match the uri used to create the passed code. From what I ...
3
votes
1answer
28 views

tagged and min max creation gives wrong total

I am trying to get the total number of question with a specific tag AND created within a specific date span. For example, the number of questions tagged as 'java' created between 16 and 17 Jan 2012: ...
1
vote
1answer
35 views

Typo in throttle violation error message

I was just playing around with the API locally and got throttled for the questions and answers methods (the only two I was using). Anyway, I noticed there’s a small typo in the error message that’s ...
0
votes
1answer
20 views

Error when requesting the last page of results.

When I try to view the following URL: http://api.stackexchange.com/2.0/questions?page=93781&site=stackoverflow I get the error: { "error_id": 500, "error_name": "internal_error", ...
2
votes
1answer
47 views

Mistake in API 2.0 Documentation - Wrong item type for Careers Message

On https://api.stackexchange.com/docs/types/inbox-item the Careers Message example shows the wrong item type.
2
votes
1answer
30 views

/users/{id}/tags/{tags}/top-answers returning answers by other users

According to the description, /users/{id}/tags/{tags}/top-answers should return answers by the user on that particular tag. Returns the top 30 answers a user has posted in response to questions ...
1
vote
1answer
13 views

Dead link in documentation

On the docs for question timelines the link for "Question" points to /docs/type/question when it should point to /docs/types/question
0
votes
1answer
22 views

No answer_id for Comment on answer inbox_item

According to the API documentation on inbox_item, inbox items corresponding to a comment on an answer to a question should have an answer_id field identifying the answer that the comment was on, but ...
2
votes
1answer
737 views

OAuth redirect not completing

This is the URL that I'm entering (in Safari, cleared website data and cache; my app, uses own Cookie jar; and incognito chrome) ...
3
votes
1answer
28 views

Stylistic error on the JavaScript SDK documentation page

There is a small stylistic error on the JavaScript SDK documentation page. Your application must have the client side OAuth flow enabled, and must not have disabled the desktop application ...
1
vote
1answer
25 views

Answer up/down vote count not being returned in filter

As the picture shows, the up_vote_count and down_vote_count answer properties are selected but not returned. What gives?
3
votes
1answer
47 views

What happens when sites or the whole network go offline

Now that the API is all done on stackexchange.com. What happens if say just certain sites go offline (eg just Stackoverflow). Will the API continue to return results or will it return the HTML offline ...