Take the 2-minute tour ×
Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.

Rewrite In Progress

I am currently in the process of completely rewriting this application from scratch. The code for the old version was an absolute disaster, written nearly four years ago when I first started learning Python. The new version will be written in Python 3 and use PyQt5.

Unfortunately I don't have a timeline on this new version but a rough guess for an early release would be early July 2014. Eventually I hope to get an actual stable release ready for Ubuntu 14.10 (Utopic) in October. Windows builds will be released when time permits.

(I will also add a link to the project page on GitHub once I am a little bit further into this.)



StackApplet is a small status icon that sits in your desktop's notification area and alerts you to events that happen to your accounts. You will receive notifications about new answers, comments and reputation changes. All Stack Exchange sites are supported. The application is written in Python and the preferences page uses JavaScript.


MIT License


Packages are available for the latest stable release (1.5.2):


Windows XP/Vista/7/8 or a Linux distribution with PyGTK installed.


I can be reached at admin@quickmediasolutions.com.


Available on Launchpad: http://launchpad.net/stackapplet

share|improve this question
The ultimate StackOverflow addict luxury. To see your reputation at all times. –  Tyler Carter May 20 '10 at 23:31
Yup. It really helps me stay on top of my rep. Are you going to try it? I am eager to hear how it works. –  Nathan Osman May 20 '10 at 23:41
@Flame: Thanks, man. I am completely new to Gnome desktop programming :) I'm assuming it worked alright, though? –  Nathan Osman May 21 '10 at 0:57
works for me. pretty cool. I've gotta say though, its a little weird when it loads Jeff Atwood's stats on the first run. –  Chris Lawlor May 27 '10 at 0:47
@George and @Chris I managed to install the sources in my home directory and set the bonobo path right. Working now! –  Peter Smit Aug 27 '10 at 18:40
both links throw 404s. perhaps they can be indexed via wayback machine if you have copies laying around? –  albert Apr 3 at 14:16

35 Answers 35

I get this error when I select the Preferences menu item on Ubuntu 14.04:

Invalid authorization credentials supplied. Please click on the preferences menu item in the application to view this page.

I reinstalled 1.5.2 and I have been getting this. All of the provided accounts from the previous installation are showing the correct rep, but I can't add new accounts.

share|improve this answer

Not sure if this is a bug on my end, but recently the application has been giving me network errors for Stack Overflow, Ask Ubuntu, and Raspberry Pi SE. I attempted reinstalling both via DEB and via the PPA, but it still was giving me errors.

So, I tried removing all of them, and then tried to add them back, but I get this:

and there are no options under Site. Is this a bug somehow, or a result of an API change or the update?

EDIT: It's now just giving me Unknown error:

unknown error

Any idea what could be causing this?

EDIT: Found the cause. There is an issue with the 1.5.1 version, 1.5.2 is working almost perfectly.

share|improve this answer

Not working for Windows (8x64)

Firstly, download links for latest 1.6 are dead

I've installed 1.5 and it doesn't show the list of sites

Find User even doesn't work.

And without the site list, even if I enter my userID it doesn't "Add Account"

share|improve this answer

I have recently become active on Arduino Beta SE and I wanted to have notifs for that on my desktop. However, StackApplet doesn't have that site in the addable (???) sites.

Is this a bug, as I know Beta sites can be added, I have Raspberry Pi working just fine; or is it just because Arduino hasn't been added to the list of sites somewhere?

share|improve this answer

Feature Request

Please add support for proxies... It would be helpful to people behind proxies. Like myself.

share|improve this answer

When you click on the icon, it brings up the window. If you click on the icon while the window is open, it pops up again, instead of closing. Just a small feature request.

Also, it would be nice if when you clicked on one of the notifications in the window, if it would get rid of the notification on the SE website. And vice versa

share|improve this answer

Is it possible to configure the app to ignore some events (specifically reputation changes in my case, not really interested in them as much as the other ones)?

share|improve this answer
As of version 1.6 (currently in Alpha), only inbox items are included in notifications (so that would include answers to your questions, comments directed to you, and anything else you would see in your global inbox). –  Nathan Osman Jun 1 '12 at 0:06

At the moment a click on the widgets in the panel doesn't have a defined action. It might be handy to have a left click on a site widget open that site in the default browser.

share|improve this answer

In version 1.6 alpha on Windows, the notification will often show

30 New Item(s)
There are 30 new item(s) in your inbox.

when there are only a few items in my inbox.

share|improve this answer

Does this work behind a proxy server?

I am trying to add my AskUbuntu Account, but the Preferences dialog just freezes after some time.

StackApplet Version is 1.4.0-2

share|improve this answer

The 64 bit version tries to install itself in the Program Files (x86) folder. I am on win 7 64 bit on an Intel i5 processor. Since the filename reads amd64 I am assuming that I might as well install the 32 bit version, is this correct?


share|improve this answer

Installed on Windows 7. On authorization, threw up a bunhc of dialogs about certificates missing, etc.

Once running, the only thing I could do is look at my Inbox - there was no list of sites, no reputation.

Removed for now, until more functionality is available.

share|improve this answer

The new 1.6 (32-bit) version won't allow me to "authorize" the app?!

I'm using a Vista OS. I've looked but haven't found any help elsewhere? Any ideas.

p.s. Stackapplet is a great tool so i'm keen to fix it. The 1.5 version works but the 1.6 doesn't. Thanks again.

share|improve this answer
I start the app. It loads. I right-click the icon. Move through the menus and click authorize. The authorize window pops ups. I click on authorize with google. It hangs indefinitely. Also, I tried other login methods and they all hang indefinitely too. It's the same whether or not I "use as admin". –  Toby Booth Jul 7 '12 at 14:52

FYI I have fully finished the Launchpad translation into Russian. Could somebody review?

(I haven't lived in Russia for 8 years and I am losing the language)

share|improve this answer

When I try to start it, I get an error message titled -

stackapplet.exe - Entry Point Not Found

saying -

The procedure entry point _except_handler4_common could not be located in the dynamic link library msvcrt.dll

What could be the reason behind this?

My platform is Windows XP Service Pack 2.

share|improve this answer
@GeorgeEdison: I am running 32-bit OS, not 64-bit.... –  Sayem Ahmed Mar 15 '12 at 19:40
@BrianFenton: Sorry about that - for some unknown reason, the permissions on that file were set to 600 instead of 644. I have fixed the permissions now, so you should be able to download the installer. –  Nathan Osman May 16 '12 at 18:19

Since you are already using a GUI toolkit (pygtk? haven't looked at the source), it doesn't make much sense to have your preferences as local website; if anything, it's a security risk.

Any chance that the Preferences feature will be rewritten with a proper GUI?

share|improve this answer

is there anything similar for KDE?

share|improve this answer

Is it possible to get notifications about badges too?

Thank you for a great app!

share|improve this answer
You're welcome! Badge notification is planned for a future release. –  Nathan Osman Jul 28 '11 at 21:16

Thank you George. It works for me (ubuntu 11) after installing via command prompt. Maybe it could be made also to start from the command prompt with the command stackapplet?

$ sudo apt-get install stackapplet Läser paketlistor... Färdig Bygger beroendeträd
Läser tillståndsinformation... Färdig Följande ytterligare paket kommer att installeras: python-gnomeapplet Följande NYA paket kommer att installeras: python-gnomeapplet Följande paket kommer att uppgraderas: stackapplet 1 att uppgradera, 1 att nyinstallera, 0 att ta bort och 224 att inte uppgradera. Behöver hämta 52,6 kB arkiv. Efter denna åtgärd kommer 79,0 MB att frigöras på disken. Vill du fortsätta [J/n]? J Läs:1 http://archive.ubuntu.com/ubuntu/ natty/main python-gnomeapplet amd64 2.32.0-0ubuntu2 [19,8 kB] Läs:2 http://archive.ubuntu.com/ubuntu/ natty/universe stackapplet all 1.4.0-1 [32,9 kB] Hämtade 52,6 kB på 0s (107 kB/s)
Väljer tidigare ej valt paket python-gnomeapplet. (Läser databasen ... 147381 filer och kataloger installerade.) Packar upp python-gnomeapplet (från .../python-gnomeapplet_2.32.0-0ubuntu2_amd64.deb) ... Förbereder att ersätta stackapplet 1.4.0 (med .../stackapplet_1.4.0-1_all.deb) ... Packar upp ersättande stackapplet ... Hanterar utlösare för bamfdaemon ... Rebuilding /usr/share/applications/bamf.index... Hanterar utlösare för desktop-file-utils ... Hanterar utlösare för python-gmenu ... Rebuilding /usr/share/applications/desktop.sv_SE.utf8.cache... Hanterar utlösare för python-support ... Ställer in python-gnomeapplet (2.32.0-0ubuntu2) ... Ställer in stackapplet (1.4.0-1) ... Hanterar utlösare för python-support ... ubuntu@ubuntu:/media/Lexar/$ stackapplet stackapplet: command not found

share|improve this answer

So I used apt-get install stackapplet, and it installed something. (Version 1.4.0-1, from the apt-cache show output.)

Then nothing happens. Should the applet automatically appear somewhere, or do I have to start it manually? If so, how?

(I have Ubuntu 11.04, with an old GNOME desktop, as my computer is too old to support Unity.)

share|improve this answer
You can start it manually by going to Applications->Accessories->StackApplet. After that, you can go to preferences and set it to start every time you log in. –  Nathan Osman Jul 26 '11 at 20:01

This is what I get with the debug version under Windows XP SP3:

C:\Program Files\StackApplet>stackapplet.exe
Traceback (most recent call last):
  File "<string>", line 88, in <module>
  File "C:\PyInstaller\iu.py", line 436, in importHook
  File "C:\PyInstaller\iu.py", line 521, in doimport
  File "Z:\tmp\a\other\windows\build\pyi.win32\stackapplet\outPYZ1.pyz/gtk", line 40, in <module>
  File "C:\PyInstaller\iu.py", line 477, in importHook
  File "C:\PyInstaller\iu.py", line 495, in doimport
  File "C:\PyInstaller\iu.py", line 297, in getmod
  File "C:\PyInstaller\archive.py", line 468, in getmod
  File "C:\PyInstaller\iu.py", line 109, in getmod
ImportError: DLL load failed: Invalid access to memory location.
share|improve this answer

Thought I'd mention. I tried setting up StackApps in Windows 7, but at the preference screen for accounts associated with StackApps, it stalls on "loading..." and I'm not able to set up my accounts. Any ideas?

share|improve this answer
Are you using Google Chrome? If so, you can right-click on the page and click "Inspect Element". There will be a console tab somewhere that may contain error information. –  Nathan Osman May 25 '11 at 6:59
@ptr: Well (and this is my fault) I actually didn't change the filenames for the different beta releases, so it's hard to tell which one you have by the filename. However, if you visit this page, you can make sure you have beta2. (Oh, and the version in the PPA now uses port 8150). –  Nathan Osman May 28 '11 at 6:03
@ptr: Good point. I'll make sure that gets fixed. Thanks for letting me know that it works! –  Nathan Osman May 28 '11 at 14:18
@ptr: Great! Actually, I develop the application in Ubuntu, so it is extremely well supported there and has some extra features. –  Nathan Osman May 29 '11 at 6:36
@ptr: Well, the only thing missing from Debian / Windows is integration with the Ubuntu Messaging Menu. All of the other features are present in other operating systems. –  Nathan Osman May 29 '11 at 20:17
@ptr: I may have a fix for the XP problem now. Please try downloading this installer and see if that fixes the problem. –  Nathan Osman Jun 13 '11 at 22:10

This neither works in WinXp nor in Debian 6 for me. What could be wrong? Nothing happens when I try to launch...

peter@debian-peter:~$ python /usr/share/stackapplet/stackapplet.py
    Traceback (most recent call last):
      File "/usr/share/stackapplet/stackapplet.py", line 116, in <module>
        import preferences     # a web server that allows preferences to be changed
      File "/usr/share/stackapplet/preferences.py", line 289, in <module>
        httpd = BaseHTTPServer.HTTPServer(('localhost', 8140), preference_server)
      File "/usr/lib/python2.6/SocketServer.py", line 402, in __init__
      File "/usr/lib/python2.6/BaseHTTPServer.py", line 108, in server_bind
      File "/usr/lib/python2.6/SocketServer.py", line 413, in server_bind
      File "<string>", line 1, in bind
    socket.error: [Errno 98] Address already in use
    peter@debian-peter:~$ python /usr/share/stackapplet/stackapplet.py
    Traceback (most recent call last):
      File "/usr/share/stackapplet/stackapplet.py", line 116, in <module>
        import preferences     # a web server that allows preferences to be changed
      File "/usr/share/stackapplet/preferences.py", line 364, in <module>
        httpd = BaseHTTPServer.HTTPServer(('localhost', 8140), preference_server)
      File "/usr/lib/python2.6/SocketServer.py", line 402, in __init__
      File "/usr/lib/python2.6/BaseHTTPServer.py", line 108, in server_bind
      File "/usr/lib/python2.6/SocketServer.py", line 413, in server_bind
      File "<string>", line 1, in bind
    socket.error: [Errno 98] Address already in use
share|improve this answer

Is there a PPA available for stackapplet?

UPDATE Feature request:

Ability to track "tagged questions" => "my filters", its cumbersome to refresh it all the time

I haven't found an app which can do that

share|improve this answer

I get the following warnings while installing your package in Ubuntu 11.04:

Lintian check results for /home/badp/Downloads/stackapplet_1.4.0_all.deb:
E: StackApplet: wrong-file-owner-uid-or-gid usr/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/applications/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/applications/stackapplet.desktop 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/en_CA/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/en_CA/LC_MESSAGES/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/en_CA/LC_MESSAGES/stackapplet.mo 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/en_GB/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/en_GB/LC_MESSAGES/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/en_GB/LC_MESSAGES/stackapplet.mo 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/es/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/es/LC_MESSAGES/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/es/LC_MESSAGES/stackapplet.mo 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/fr/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/fr/LC_MESSAGES/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/fr/LC_MESSAGES/stackapplet.mo 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/tr/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/tr/LC_MESSAGES/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/locale/tr/LC_MESSAGES/stackapplet.mo 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/pixmaps/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/pixmaps/meta.stackoverflow.png 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/pixmaps/serverfault.png 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/pixmaps/stackapplet.png 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/pixmaps/stackapplet_grey.png 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/pixmaps/stackapplet_light.png 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/pixmaps/stackapps.png 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/pixmaps/stackoverflow.png 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/pixmaps/superuser.png 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/stackapplet/ 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/stackapplet/appindicator_replacement.py 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/stackapplet/config_store.py 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/stackapplet/import_13.py 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/stackapplet/prefs_dialog.py 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/stackapplet/select_user.py 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/stackapplet/stack_api.py 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/stackapplet/stackapplet.glade 1000/1000
E: StackApplet: wrong-file-owner-uid-or-gid usr/share/stackapplet/stackapplet.py 1000/1000
share|improve this answer

Is there support for http proxies?

share|improve this answer
Not at this point. Which platform are you using? –  Nathan Osman Apr 27 '11 at 19:07

Nice one! But…


This notifier may be dangerous to epileptic users having rep like Jon Skeet


share|improve this answer

I'm installing Ubuntu 11.04; I saw StackApplet in the Accessories menu. It claims that as of the newly installed version 1.4, StackApplet is no longer a Gnome 2 applet, but instead it'll live in the tray area... except I'm not even sure Ubuntu 11.04's Unity will have a tray area to begin with. Kinda baffled by the coincidence.

At any rate, can you please consider improving the way the tray icon behaves? Currently it does nothing on right click and opens a menu in place on left click; if the tray bar is placed at the bottom of the screen, this puts the 'Quit' menu item squarely below where I clicked. Basically, clicking on the StackApplet icons closes it; I'd have to drag up to use the program itself.

share|improve this answer

Feature Request:

Would it be possible to add a preference where I can point the app to an accounts page (like this one) and it automatically picks up all accounts from there? Possibly even monitor that page for new appearing accounts?

Because it is rather tedious to enter all those accounts individually and it should be very easy to retrieve the data for the app.

BTW: thanks for writing the app!!


Wait, I just noticed the "Check for associated accounts" preference in the current version, I guess that cancels out my request. Still:

  1. Unfortunately the app does not check for duplicates (a duplicate being a two entries with equal site and user id)
  2. it would be even nicer if the app could continually monitor the accounts and add new accounts automatically once they appear.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .