Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Rewrite In Progress

I am currently in the process of completely rewriting this application from scratch. The code for the old version was an absolute disaster, written nearly four years ago when I first started learning Python. The new version will be written in Python 3 and use PyQt5.

Unfortunately I don't have a timeline on this new version but a rough guess for an early release would be early July 2014. Eventually I hope to get an actual stable release ready for Ubuntu 14.10 (Utopic) in October. Windows builds will be released when time permits.

(I will also add a link to the project page on GitHub once I am a little bit further into this.)

Screenshot

About

StackApplet is a small status icon that sits in your desktop's notification area and alerts you to events that happen to your accounts. You will receive notifications about new answers, comments and reputation changes. All Stack Exchange sites are supported. The application is written in Python and the preferences page uses JavaScript.

License

MIT License

Download

Packages are available for the latest stable release (1.5.2):

Platform

Windows XP/Vista/7/8 or a Linux distribution with PyGTK installed.

Contact

I can be reached at admin@quickmediasolutions.com.

Source

Available on Launchpad: http://launchpad.net/stackapplet

share|improve this question
33  
The ultimate StackOverflow addict luxury. To see your reputation at all times. – Tyler Carter May 20 '10 at 23:31
2  
Yup. It really helps me stay on top of my rep. Are you going to try it? I am eager to hear how it works. – Nathan Osman May 20 '10 at 23:41
    
You might want to use f = open(os.path.join(os.getenv("HOME"),"/.stackoverflow"),'r') to open your settings. – Flame May 21 '10 at 0:37
1  
@Flame: Thanks, man. I am completely new to Gnome desktop programming :) I'm assuming it worked alright, though? – Nathan Osman May 21 '10 at 0:57
    
George, would you mind if I 'borrowed' your stackoverflow icon? At least until there are "official" releases of icons/images? – Nick Presta May 21 '10 at 4:19
    
@Nick: Sure. Help yourself. – Nathan Osman May 21 '10 at 5:09
3  
works for me. pretty cool. I've gotta say though, its a little weird when it loads Jeff Atwood's stats on the first run. – Chris Lawlor May 27 '10 at 0:47
    
@Chris: Well... it kind of has to display something when it first starts. Do you have any ideas of what would you like to see it display? – Nathan Osman May 27 '10 at 0:52
    
@George something simple like 'Configure User'. Should be easy to default to userid = 0 or -1 or null, and check for that at startup. – Chris Lawlor May 28 '10 at 13:44
    
Too bad it doesn't support multiple instances (so I can track my rep on more than one site), otherwise great! :) – Felix Jun 9 '10 at 19:33
    
@Felix: Don't worry - I am planning to fix that :) – Nathan Osman Jun 10 '10 at 0:24
    
You now get notifications when comments are posted to you. – Nathan Osman Jun 23 '10 at 6:48
    
StackApplet worked very well for me for a week or so, but suddenly it started displaying "HTTP Error" and no matter what I do I can't get it to work again. It doesn't even show an icon. Is this something known? – Peter Jaric Jun 28 '10 at 19:32
1  
@George and @Chris I managed to install the sources in my home directory and set the bonobo path right. Working now! – Peter Smit Aug 27 '10 at 18:40
1  
both links throw 404s. perhaps they can be indexed via wayback machine if you have copies laying around? – albert Apr 3 '14 at 14:16

38 Answers 38

Since you are already using a GUI toolkit (pygtk? haven't looked at the source), it doesn't make much sense to have your preferences as local website; if anything, it's a security risk.

Any chance that the Preferences feature will be rewritten with a proper GUI?

share|improve this answer
    
The small HTTP server that manages the preferences is quite secure - it uses a cryptographic nonce to ensure that only the current user can make changes to it. But yes, I am planning to rewrite the application in Qt and this will include a brand new dialog box for preferences. – Nathan Osman Jan 10 '12 at 0:44

Does this work behind a proxy server?

I am trying to add my AskUbuntu Account, but the Preferences dialog just freezes after some time.

StackApplet Version is 1.4.0-2

share|improve this answer
    
I would strongly suggest upgrading to 1.5.1 which is the latest stable release. A lot of bugs were fixed in that release. – Nathan Osman Dec 10 '12 at 3:34

When you click on the icon, it brings up the window. If you click on the icon while the window is open, it pops up again, instead of closing. Just a small feature request.

Also, it would be nice if when you clicked on one of the notifications in the window, if it would get rid of the notification on the SE website. And vice versa

share|improve this answer

Feature Request

Please add support for proxies... It would be helpful to people behind proxies. Like myself.

share|improve this answer

Not sure if this is a bug on my end, but recently the application has been giving me network errors for Stack Overflow, Ask Ubuntu, and Raspberry Pi SE. I attempted reinstalling both via DEB and via the PPA, but it still was giving me errors.

So, I tried removing all of them, and then tried to add them back, but I get this:

and there are no options under Site. Is this a bug somehow, or a result of an API change or the update?

EDIT: It's now just giving me Unknown error:

unknown error

Any idea what could be causing this?

EDIT: Found the cause. There is an issue with the 1.5.1 version, 1.5.2 is working almost perfectly.

share|improve this answer

I get this error when I select the Preferences menu item on Ubuntu 14.04:

Invalid authorization credentials supplied. Please click on the preferences menu item in the application to view this page.

I reinstalled 1.5.2 and I have been getting this. All of the provided accounts from the previous installation are showing the correct rep, but I can't add new accounts.

share|improve this answer

I don't know what is the application normal behavior, but I'm only able to see my reputation on a lot of SE sites, while I don't receive any notification at all (such as when someone comments/replies to a question of mine). Is this normal? I'm on Ubuntu 14.04 x64 and I'm using the 1.5.2 version

share|improve this answer

Stuck at "add a new account" with v.1.5.2, Ubuntu 15.04 64-bit

After a long break (due to unsolved problems) I tried using this applet again today following the up-to-date installation procedures (basically using the latest PPA and remembering to check that python-appindicator is installed) but unfortunately this time I couldn't even start logging into my account no matter what I did -- entering my user name or my email address or using "Find User", etc.

I started the applet from terminal to see any error messages, but nothing was there to see either.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .