Take the 2-minute tour ×
Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.

I'm testing curious usernames and I am searching their user_id by:

http://api.stackoverflow.com/0.8/users/?filter=username_filter

I'm trying to get information about this particular user:

http://stackoverflow.com/users/190597/unutbu

http://api.stackoverflow.com/0.8/users/?filter=unutbu returns nothing.

I know this is a corner case; the only thing I found is the Meta Stack Overflow post A last tribute to the Tilde although I'm not sure if it is related to the same problem.

share|improve this question
    
I see no tilde here. –  Dennis Williamson Jun 7 '10 at 11:29
    
you can see it here (bottom-left): stackoverflow.com/users?page=11 –  systempuntoout Jun 7 '10 at 12:23
    
This is [status-bydesign] for now. –  Kevin Montrose Jun 8 '10 at 8:42
add comment

2 Answers

up vote 1 down vote accepted

From Jeff's answer to the deleted question* linked to from the question you link to:

Your name is inferred from your openid until you specify a display name. You have no display name specified.

Thus your inferred username is ...

~quack

... because it's based on your openid URL. It's not an actual, valid display name.

If you check unutbu's page there's no name specified.

* visible only to 10K+ meta users.

share|improve this answer
    
thanks. –  systempuntoout Jun 7 '10 at 12:28
add comment

Here's Jeff's answer to a question that hasn't been deleted.

These users don't actually have names; we're synthesizing a fake name based on their OpenID string.

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .