Sign up ×
Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.


The Close Reason Editor allows you edit the off-topic close reasons which are normally editable only by the site moderators.

Close Dialog

Show or hide the default off-topic close reasons

If, for some reason, you do not agree with the default close reasons, or you rarely need some of them, you can hide* them from the close dialog by deactivating them.

*: They will still show up in the close dialog if someone else has already chosen that reason for that particular question.

Default Off-Topic Close Reasons

Save your favorite custom off-topic close reasons

You no longer have to type your most commonly used close reasons over and over again. Simply save them once, and you can use them just the way you want.

Custom Off-Topic Close Reasons


  • You need to have the "cast close and reopen votes" privilege (3000 reputation on graduated sites) in order to use the custom close reasons.
  • You have to use a browser that supports localStorage.


share|improve this question
+1, awesome! I'd thought about writing a script to do something like this myself, but now I don't have to! :-) And the user interface you've got is incredibly polished. –  Ilmari Karonen Feb 18 '14 at 22:02
Now make one where I can see instantly who is on-line (not in the Chat room) but in the Q&A. –  Buscar웃 May 22 at 5:40

2 Answers 2

I ran into a problem, using Firefox ver. 38...

The adding of Tags to a new question initiates a scripting error and does not let me add tags.

If I turn off the close-reason-editor I am back to normal.

When I try to ask new question, and click on add tags, I get the Firefox to freeze with spinning beach ball followed by Error message.

This is the output:

Use of getAttributeNode() is deprecated. Use getAttribute() instead. jquery.min.js:2:0
Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. jquery.min.js:3:0
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More]
Error: Script terminated by timeout at:

enter image description here

share|improve this answer
Can you open the JavaScript console and post the error message here? And what do you mean by "adding tags to a new question"? Are you on /questions/ask, /posts/{id}/edit or /posts/{id}/edit-inline? –  Antony May 24 at 14:41
I am unable to reproduce the issue on Firefox 38 on a Mac on the "Ask Question" page. Please refer to this post on how to open the JavaScript console, and include relevant details in the bug report, e.g. the error message you see in the console, the URL of the page you where encounter the problem, a screenshot of the error, or any other information that may help explain the issue. –  Antony May 26 at 2:19
Will do, I removed the script since it was bugging me. Now I have to install it and report. Might be a while :) –  Buscar웃 May 26 at 2:25
@Antony OK, installed and running, nothing so far. –  Buscar웃 May 26 at 2:29
Thanks for the report. The bug has been fixed. Please update the userscript to the new version. –  Antony May 26 at 14:17
I had the same thing (haven't tried the updated script yet). Were you also getting a confirmation dialogue each time you attempted to post a question or answer? –  terdon Sep 16 at 14:31

This script caused me both the bug reported by Buscar and the one reported here (I was asked to confirm leaving the page each time I posted a question or answer).

Removing the script solved both bugs and, since I don't really use it, I can live with that. I won't be following up on this but I thought it was worth reporting.

share|improve this answer
This is probably related to wmd.en.js being loaded twice. I have fixed this in the latest version of the script. Can you please update it to test it for me? I know you don't really use it, but making sure this is fixed properly would benefit those who do use the script. –  Antony Sep 16 at 16:16
@Antony I did try the new version you have in your answer before posting this. I still had the confirmation bug. Let me know if you update it again and I'll give it a go. –  terdon Sep 16 at 16:44
Are you using version 1.1.5? I just updated it an hour ago. –  Antony Sep 16 at 17:09
@Antony oh, sorry, I was looking at the time the OP was edited. OK, I'll try this tomorrow (no time now). –  terdon Sep 16 at 17:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .