Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm making an app for Windows Phone using the Stack Exchange API but I'm having a bit of trouble when I try to let the user approve the application (using client side flow).

I open a web browser at the following URL:

https://stackexchange.com/oauth/dialog?client_id=1464&scope=read_inbox&redirect_uri=https://stackexchange.com/oauth/login_success

On my PC this displays fine:

enter image description here

But on the phone I do not see the You need to login to authorize this application section.

enter image description here

This is the same on the emulator and a physical device. Is this a bug? Am I missing something?

share|improve this question
up vote 0 down vote accepted

It appears you have to specifically enable JavaScript for the WebBrowser control on Windows Phone.

<phone:WebBrowser x:Name="webBrowser" IsScriptEnabled="True" />
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .