Take the 2-minute tour ×
Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.

I want to create a simple desktop application which connects to my account and shows some information in the status bar. I've been trying to authenticate using OAuth2.0 but I'm getting stuck and I cannot see what I´m doing wrong.

The steps I've followed are:

  1. I've registered my application
  2. Checked the option "Enable Client Side OAuth Flow"
  3. Call

    https://stackexchange.com/oauth?client_id=997&scope=read_inbox,private_info&redirect_uri=https://stackexchange.com/oauth/login_success
    
  4. I authenticate using my google account and grant access

From what I understood after reading the documentation is that I should get a redirect to this URL:

https://stackexchange.com/oauth/login_success

with my token in the query string. Instead, I'm getting this:

https://stackexchange.com/oauth/login_success?error=unauthorized_client&error_description=This+application+has+been+registered+for+implicit+grants%2c+and+cannot+requests+codes

error message:

This application has been registered for implicit grants, and cannot requests codes

I've tried several scope options with the same result.

What am I doing wrong?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

The implicit flow uses the url https://stackexchange.com/oauth/dialog, not https://stackexchange.com/oauth.

You should just need to change the url, otherwise that looks correct.

share|improve this answer
add comment

The fix for me was unchecking "Enable Client Side OAuth Flow"

share|improve this answer
1  
Confirmed that this worked for me too. Not sure why it was downvoted. –  Nick Sullivan Jan 30 at 5:17
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .