Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to understand how edit-comment method could be used.

I passed valid token with write_access, valid key, and existed comment id, but all I've got is:

  "error_id": 405,
  "error_name": "key_required",
  "error_message": "`key` is required when `access_token` is passed."

Then I tried random id, key and token - same result.

Also I've tried to call this method via api.stackexchange and get another error:

{"error_id":404,"error_name":"no_method","error_message":"this method cannot be called this way"}

What am I doing wrong?

ps: I'm having similar problems with create-comment and delete-comment methods.

share|improve this question

You must log in to answer this question.

Browse other questions tagged .