Take the 2-minute tour ×
Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.

I think I may have stumbled upon a bug in the StackExchange JS API

I'm having a problem getting its authentication to work properly, and I just discovered that the same problem exist in the official StackExchange API example in the documentation!

To see the problem in action, do the following:

  1. Make sure you are NOT signed in to StackExchange. (go here https://stackexchange.com/ the to header should not display your name)
  2. Go to https://api.stackexchange.com/docs/js-lib and press the "Run Example With Version XXXX" button at the bottom of the page
  3. You should see a popup appear with the message "Application Login Failure - An error occurred while login into an application" pressing the "show more details link will show "could not parse proxy url".

The second time you press that button, everything works since you got sign in on the first (failed) attempt.

This problem only occurs if you sign in at least once before to SE, so if you get a popup with the 4 ways to sign in to SE (SE, Google, Facebook, Yahoo), sign in should work.

To see this bug you now retry from step 1 (you won't get the 4 buttons now)

Any ideas about what to do next here ? Any help will be greatly appreciated!

share|improve this question
add comment

migrated from stackoverflow.com Sep 5 '12 at 7:37

This question came from our site for professional and enthusiast programmers.

1 Answer

Oy, that was an annoying one.

Subtle, as the bug only happened when you're not logged in but would be automatically logged in when you visit stackexchange.com.

The actual root cause was just over-encoding a url.

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .