Take the 2-minute tour ×
Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.

I think I must be doing something very stupid, that I just can't see

I just registered an app, in the last ~10 minutes.

I have just been going to the /info route, no authentication or anything else.

The Quota Max says 300, I thought it was supposed to be 10,000 if you have a key?

More bizarrely the Quota remaining is negative, not just in that it has a - sign before, but the absolute value of it increases between requests, e.g. from -3700 to -3701.

I've haven't made anywhere near 300 requests, let alone the 4000 it seem to be reporting.

It doesn't matter whether I include the key or not, the Quota values are the same. It is also the same problem on the questions route, so it is not just Info.

I am only doing Unit tests, so there is no way I have accidentally sent 1000s of requests at once.

I hesitate to tag this as bug, because likely I've done something wrong.

share|improve this question
    
No, this is a bug I'm pretty sure. An odd one I can't reproduce, but I've got some other reports of it so I'm sure it's happening. I'll be deploying some extra instrumentation to figure it out soon-ish. –  Kevin Montrose Dec 30 '11 at 0:00
    
If there's anything I give you (url, response etc) to help, just say. –  Jonathan. Dec 30 '11 at 0:26
    
A potential fix has been deployed, let me know if it happens again. I'm leaving some logging stuff around for a few more days to see if it comes back. –  Kevin Montrose Dec 30 '11 at 2:26
    
It seems to be fixed now. Thanks –  Jonathan. Dec 30 '11 at 9:30
    
@KevinMontrose, this bug is back again, the docs API console returns ~-300, and without a key returns ~-10400, one of my keys returns ~-700 –  Jonathan. Jan 2 '12 at 14:50
    
there's been another round of fixes around this, think I figured it out. (Combo of code and networking oddities). –  Kevin Montrose Jan 3 '12 at 20:18
add comment

1 Answer

up vote 1 down vote accepted

Monitoring code has been watching quotas for "impossible" values for a few weeks now and not seen anything, looks like the last round of fixes knocked it out.

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .