Take the 2-minute tour ×
Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.

I'm playing with the oauth2 support in v2-beta with an http client that doesn't support gzip decoding. (My client is http spec compliant but can't deal with the non-compliance of the api on this issue). Am I out of luck?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Starting in V2, the API will honor deflate Accept-Encodings (it still defaults to GZIP in the absence of an Accept-Encoding). So, if deflate is an option then you've got a work around.

I'm curious as to what client you're using that doesn't support GZIP? That's kind of egregious in 2011.

share|improve this answer
    
I'm using the MarkLogic built-in client, which unfortunately does not support gzip or deflate. I agree it's a bit egregious. –  Eric Bloch Dec 7 '11 at 17:05
    
@Eric: You could use a proxy that supports GZIP - for example, you could have another application running locally that makes the requests and then have your app just send the request to the local proxy. –  Nathan Osman Dec 7 '11 at 18:14
    
@Eric - hmm, reading over that documentation it looks like under some conditions you'll get a binary object back as the second node. If that's the case, is there any way to get a hold of zlib or similar in your app? –  Kevin Montrose Dec 7 '11 at 18:18
1  
Also, I'm glad to here that just plain-old DEFLATE is now supported. Now I can use the API with an unmodified version of Qt, which only provides DEFLATE decompression by default. –  Nathan Osman Dec 7 '11 at 20:52
    
@George - when I try to make a request via an apache proxy, I get the following error: {"error_id":400,"error_name":"bad_parameter","error_message":"site is required"} –  Eric Bloch Dec 16 '11 at 23:10
    
@EricBloch: Are you passing site as a query string parameter? –  Nathan Osman Dec 16 '11 at 23:13
    
@George d'oh thanks, I forgot about that. –  Eric Bloch Dec 17 '11 at 1:56
    
@NathanOsman I am having the same problem, and I am passing site=stackoverflow in the query string. –  Zev Eisenberg Jul 4 at 5:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .