Take the 2-minute tour ×
Stack Apps is a question and answer site for apps, scripts, and development with the Stack Exchange API. It's 100% free, no registration required.

When processing http://api.stackoverflow.com/1.0/questions/1156985 I only get partial results. Many of the missing fields are mandatory fields, including the owner of the question.

share|improve this question
    
If you look at the actual question, you'll see that the owner is deleted/unregistered. –  Dennis Williamson Aug 6 '10 at 19:02
    
One thing that is a bit unclear in the docs is where the underlying structures are optional - or should I assume ALL are optional by default. Yes, I get that collections can be empty, but structs like Owner, I would expect to be populated when their fields are mandatory. Otherwise, the documentation of the structures is excellent. –  user1749 Aug 6 '10 at 19:48
1  
See my feature request: stackapps.com/questions/1083/… –  jjnguy Aug 6 '10 at 20:45
add comment

1 Answer

As Dennis pointed out, there is no owner (effectively) on that question.

That the API does not return a displayable "no user" string in these (and related) cases is an acknowledge deficiency which will be rectified in a subsequent version.

share|improve this answer
    
Thanks Kevin. Very helpful. I will just add logic to handle this for now. –  user1749 Aug 6 '10 at 19:59
1  
@Rich here is where I brought up the issue: stackapps.com/questions/1083/… –  jjnguy Aug 6 '10 at 20:44
add comment

You must log in to answer this question.